null(4) BSD Kernel Interfaces Manual null(4)
null -- the null device
The null device accepts and reads data as any ordinary (and willing) file - but throws it away. The length of the null device is always zero.
A null device appeared in Version 7 AT&T UNIX. BSD June 5, 1993 BSD
Mac OS X 10.9 - Generated Wed Oct 16 18:03:30 CDT 2013