hosts(5) BSD File Formats Manual hosts(5)
hosts -- host name data base
The hosts file contains information regarding the known hosts on the net- work. For each host a single line should be present with the following information: Internet address Official host name Aliases Items are separated by any number of blanks and/or tab characters. A ``#'' indicates the beginning of a comment; characters up to the end of the line are not interpreted by routines which search the file. Network addresses may either be specified for IP version 4 or version 6. IP version 4 addresses are specified in the conventional dotted address notation. IP version 6 addresses are specified using the colon-separated notation described in RFC1924. Host names may contain any printable character other than a field delim- iter, newline, or comment character. The hosts file is read by mDNSResponder(8) and used to supply results for calls to getaddrinfo(3), getnameinfo(3), etc. in addition to results obtained from multicast and unicast DNS.
gethostent(3), getipnodebyname(3), getaddrinfo(3), getnameinfo(3) RFC1924: A Compact Representation of IPv6 Addresses.
The hosts file format appeared in 4.2BSD. 4.2 Berkeley Distribution December 11, 1993 4.2 Berkeley Distribution
Mac OS X 10.8 - Generated Sat Sep 1 12:45:13 CDT 2012