protocols(5) BSD File Formats Manual protocols(5)
protocols -- protocol name data base
The protocols file contains information regarding the known protocols used in the DARPA Internet. For each protocol a single line should be present with the following information: official protocol name protocol number aliases Items are separated by any number of blanks and/or tab characters. A ``#'' indicates the beginning of a comment; characters up to the end of the line are not interpreted by routines which search the file. Protocol names may contain any printable character other than a field delimiter, newline, or comment character.
INTERACTION WITH DIRECTORY SERVICES
Processes generally find protocol records using one of the getprotoent(3) family of functions. On Mac OS X, these functions interact with the DirectoryService(8) daemon, which reads the /etc/protocols file as well as searching other directory information services to determine protocol name and number information.
The protocols file format appeared in 4.2BSD. 4.2 Berkeley Distribution June 5, 1993 4.2 Berkeley Distribution
Mac OS X 10.8 - Generated Sat Sep 1 14:42:18 CDT 2012