ssh-keysign(8) BSD System Manager's Manual ssh-keysign(8)
ssh-keysign -- ssh helper program for host-based authentication
ssh-keysign is used by ssh(1) to access the local host keys and generate the digital signature required during host-based authentication. ssh-keysign is disabled by default and can only be enabled in the global client configuration file /opt/local/etc/ssh/ssh_config by setting EnableSSHKeysign to ``yes''. ssh-keysign is not intended to be invoked by the user, but from ssh(1). See ssh(1) and sshd(8) for more information about host-based authentica- tion.
/opt/local/etc/ssh/ssh_config Controls whether ssh-keysign is enabled. /opt/local/etc/ssh/ssh_host_dsa_key /opt/local/etc/ssh/ssh_host_ecdsa_key /opt/local/etc/ssh/ssh_host_ed25519_key /opt/local/etc/ssh/ssh_host_rsa_key These files contain the private parts of the host keys used to generate the digital signature. They should be owned by root, readable only by root, and not accessible to others. Since they are readable only by root, ssh-keysign must be set-uid root if host-based authentication is used. Note that ssh-keysign is not set-uid by default on Mac OS X. /opt/local/etc/ssh/ssh_host_dsa_key-cert.pub /opt/local/etc/ssh/ssh_host_ecdsa_key-cert.pub /opt/local/etc/ssh/ssh_host_ed25519_key-cert.pub /opt/local/etc/ssh/ssh_host_rsa_key-cert.pub If these files exist they are assumed to contain public certifi- cate information corresponding with the private keys above.
ssh-keysign first appeared in OpenBSD 3.2.
Markus Friedl <email@example.com> BSD April 9, 2016 BSD
openssh 7.2p2 - Generated Sat Apr 9 07:55:05 CDT 2016