umount(8) BSD System Manager's Manual umount(8)
umount -- unmount filesystems
umount [-fv] special | node umount -a | -A [-fv] [-h host] [-t type]
The umount command calls the unmount(2) system call to remove a special device or the remote node (rhost:path) from the filesystem tree at the point node. If either special or node are not provided, the appropriate information is taken from the list of filesystems provided by getfsent(3). The options are as follows: -a All the filesystems described via getfsent(3) are unmounted. -A All the currently mounted filesystems except the root are unmounted. -f The filesystem is forcibly unmounted. Active special devices continue to work, but all other files return errors if further accesses are attempted. The root filesystem cannot be forcibly unmounted. -h host Only filesystems mounted from the specified host will be unmounted. This option implies the -A option and, unless other- wise specified with the -t option, will only unmount NFS filesys- tems. -t type Is used to indicate the actions should only be taken on filesys- tems of the specified type. More than one type may be specified in a comma separated list. The list of filesystem types can be prefixed with ``no'' to specify the filesystem types for which action should not be taken. For example, the umount command: umount -A -t nfs,hfs umounts all currently-mounted filesystems of the type NFS and HFS. (The -a option only unmounts entries in the /etc/fstab list.) -v Verbose, additional information is printed out as each filesystem is unmounted.
Due to the complex and interwoven nature of Mac OS X, umount may fail often. It is recommended that diskutil(1) (as in, ``diskutil unmount /mnt'') be used instead.
unmount(2), getfsent(3), mount(8), diskutil(1)
A umount command appeared in Version 6 AT&T UNIX. 4th Berkeley Distribution May 8, 1995 4th Berkeley Distribution
OS X 10.10 - Generated Fri Nov 7 20:35:30 CST 2014